Dutch national flag problem in Javascript

Image
Dutch national flag problem and solution in Javascript Problem statement:   The Dutch national flag (DNF) problem is one of the most popular programming problems proposed by Edsger Dijkstra. The flag of the Netherlands consists of three colors: white, red, and blue. The task is to randomly arrange balls of white, red, and blue such that balls of the same color are placed together. Now, let's consider an array with 3 distinct values say 0, 1 and 2. We won't be using any sort method and we need to sort this array in 0(n). Input Array :  let   arr  = [ 0 ,  2 ,  1 ,  0 ,  1 ,  2 ,  0 ,  2 ]; Expected Output: [ 0, 0, 0, 1, 1, 2, 2, 2 ] Solution Approach : When we see expected output, we can clearly see that sorted array is divided into 3 sections having values 0 , 1 and 2. So, let's divide the array in 3 sections: a) from 0th index to left boundary b) from left boundary to right boundary c) from right boundary to last index. Now we will create 2 pointers : left (starting from 0

Recover the Arrays: Hourrank 19 Problem and Solution in java

Recover the Arrays: Hourrank 19 Problem
Dani is writing some arrays in her favorite text editor HackerEdit. Each line of the document describes an array in the following format:
Here  is the array's number of elements and  are its contents.
Dani wrote  arrays in the file and left for lunch. To her dismay, her little brother Nik deleted all the newline characters from the file while she was gone! For example, consider the file in the table below:
image
Given the contents of Dani's HackerEdit file with all the newlines removed, find the value of  (i.e., the number of arrays in the initial file).
Input Format
The first line contains an integer denoting  (the number of integers in the file). 
The second line contains  space-separated integers describing each respective value in the file.
Constraints
Output Format
Print a single integer denoting .
Sample Input 0
11
5 4 5 4 3 3 2 1 4 1 4
Sample Output 0
3
Explanation 0
The file looks like this after removing all the newlines:
image
After re-adding the newlines where they belong in the file, it looks like this:
image
Because there are three arrays declared in the reconstructed file, we print  as our answer.
Solution in java:
import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;

public class Solution {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int n = in.nextInt();
        int[] file = new int[n];
        for(int file_i=0; file_i < n; file_i++){
            file[file_i] = in.nextInt();
        }
        int count =0;
        for(int i=0;i<n;i++){
        int    init=file[i];
            i=i+init;
            count++;
        }
           System.out.println(count);  //  Print the number of arrays defined in 'file' to STDOUT.
   
    }
}

Comments

Popular posts from this blog

Ice Cream Parlor : Hackerrank Problem and Solution

Javascript Problem: Find the next perfect square!!

Disemvowel Trolls || Codewars problem and solution in Javascript || Topic : Strings and RegEx